Join our server

Update version 2019.10.3, build 191018.2110


#1

I accidentally broke a couple of things in the last build, so I’ve tried to fix them and some others without breaking too many new ones.

  • Commander assignment for custom battles should now work, dividing the units evenly among all the players on a team
  • Only the hosting player is now given control over the match slots of custom battles, and is able to remove players from slots
  • Fixed deleting downloaded custom maps (those with time stamped names)
  • Fixed unit spawning so they are facing the map center in sandbox and custom battles
  • Fixed multi-selection select/deselect tap
  • Fixed units facing the wrong way when halted by double-tap
  • Fixed info panel not automatically closing when battle starts
  • Fixed a couple of crashes, especially the one caused by multi-touch selection gesture

(The update has just been submitted so it can take some hours for Play Store and some days for App Store before it is available. I’ll post a note here when it is up.)


#2

Regarding the UI getting smaller in the last build, I did not intentionally change anything, so it may be something with the new version of XCode or iOS/iPadOS. I did some testing on my devices and although I did notice the difference I found it acceptable. But then, I do not have the latest models of those devices, so if you think I need to change the UI size, let me know what model you’re using and your opinion


#3

iPad pro 12.9 inch gen 3
Might be a difficult issue to tackle because there is a dock minimization instead of a home button
Takes up a whole line of ui at the bottom


#4

the update should be available in both the Play Store and App Store now


#5

yes, I noticed that, and similar for the notch on the iPhone. I haven’t tested how it feels on a real device (only the simulator), do you think it’s a problem UI-wise?


#6

I don’t believe it’s a big issue, however if the ui was to be bigger for top and bottom, then there would be a tiny fraction less screen space to play with

nevermind, didn’t update


#7

Are you running 191018.2110 and could you describe how to reproduce the crash? that would be very helpful


#8

Man thanx man…many important issues!


#9

Internet issues, didn’t update, crash is fixed


#10

Command buttons in custom still not working